集团站切换校区

验证码已发送,请查收短信

图标

学习文章

当前位置:首页 > >学习文章 > >

{思科CCIE-RS}MPLS VPN BY乱雪纷飞

发布时间: 2017-10-12 17:18:18

BY乱雪纷飞

多协议标签交换MPLS(Multiprotocol Label Switching)是一种IP(Internet Protocol)骨干网技术。MPLS在无连接的IP网络上引入面向连接的标签交换概念,将第三层路由技术和第二层交换技术相结合,充分发挥了IP路由的灵活性和二层交换的简捷性。


MPLS起源于IPv4(Internet Protocol version 4),其核心技术可扩展到多种网络协议,包括IPv6(Internet Protocol version 6)、IPX(Internet Packet Exchange)和CLNP(Connectionless Network Protocol)等。MPLS中的“Multiprotocol”指的就是支持多种网络协议。


由此可见,MPLS并不是一种业务或者应用,它实际上是一种隧道技术。这种技术不仅支持多种高层协议与业务,而且在一定程度上可以保证信息传输的安全性。


R1:

hostname R1

!

no ip domain lookup

ip cef

no ipv6 cef

!

mpls label range 100 199

mpls label protocol ldp

!

interface Loopback0

ip address 1.1.1.1 255.255.255.255

!

interface Ethernet0/0

ip address 12.1.1.1 255.255.255.0

mpls ip

!

interface Ethernet0/1

ip address 13.1.1.1 255.255.255.0

mpls ip

!

router eigrp 90

network 1.1.1.1 0.0.0.0

network 12.1.1.1 0.0.0.0

network 13.1.1.1 0.0.0.0

!

mpls ldp router-id Loopback0


R2:

hostname R2

!

ip vrf ccie

rd 100:100

route-target export 4:5

route-target import 5:4

!

no ip domain lookup

ip cef

!

mpls label range 200 299

mpls label protocol ldp

!

interface Loopback0

ip address 2.2.2.2 255.255.255.255

!

interface Ethernet0/0

ip address 12.1.1.2 255.255.255.0

mpls ip

!

interface Ethernet0/1

ip vrf forwarding ccie

ip address 24.1.1.2 255.255.255.0

!

router eigrp 90

network 2.2.2.2 0.0.0.0

network 12.1.1.0 0.0.0.255

network 24.1.1.0 0.0.0.255

!

router bgp 123

bgp router-id 2.2.2.2

bgp log-neighbor-changes

no bgp default ipv4-unicast

neighbor 3.3.3.3 remote-as 123

neighbor 3.3.3.3 update-source Loopback0

!

address-family ipv4

neighbor 3.3.3.3 activate

neighbor 3.3.3.3 next-hop-self

exit-address-family

!

address-family vpnv4

neighbor 3.3.3.3 activate

neighbor 3.3.3.3 send-community extended

exit-address-family

!

address-family ipv4 vrf ccie

redistribute static

exit-address-family

!

ip route vrf ccie 4.4.4.4 255.255.255.255 24.1.1.4

!

mpls ldp router-id Loopback0


R3:

hostname R3

!

ip vrf ccie

rd 100:100

route-target export 5:4

route-target import 4:5

!

no ip domain lookup

ip cef

!

mpls label range 300 399

mpls label protocol ldp

!

interface Loopback0

ip address 3.3.3.3 255.255.255.255

!

interface Ethernet0/0

ip vrf forwarding ccie

ip address 35.1.1.3 255.255.255.0

!

interface Ethernet0/1

ip address 13.1.1.3 255.255.255.0

mpls ip

!

router eigrp 90

network 3.3.3.3 0.0.0.0

network 13.1.1.0 0.0.0.255

network 35.1.1.0 0.0.0.255

!

router bgp 123

bgp router-id 3.3.3.3

bgp log-neighbor-changes

no bgp default ipv4-unicast

neighbor 2.2.2.2 remote-as 123

neighbor 2.2.2.2 update-source Loopback0

!

address-family ipv4

neighbor 2.2.2.2 activate

neighbor 2.2.2.2 next-hop-self

exit-address-family

!

address-family vpnv4

neighbor 2.2.2.2 activate

neighbor 2.2.2.2 send-community extended

exit-address-family

!

address-family ipv4 vrf ccie

redistribute static

exit-address-family

!

ip route vrf ccie 5.5.5.5 255.255.255.255 35.1.1.5

!

mpls ldp router-id Loopback0


R4:

hostname R4

!

no ip domain lookup

ip cef

!

interface Loopback0

ip address 4.4.4.4 255.255.255.255

!

interface Ethernet0/1

ip address 24.1.1.4 255.255.255.0

!

ip route 0.0.0.0 0.0.0.0 24.1.1.2


R5:

hostname R5

!

no ip domain lookup

ip cef

!

interface Loopback0

ip address 5.5.5.5 255.255.255.255

!

interface Ethernet0/0

ip address 35.1.1.5 255.255.255.0

!        

ip route 0.0.0.0 0.0.0.0 35.1.1.3

上一篇: {思科CCIE-RS}IP SLA BY乱雪纷飞

下一篇: {思科CCIE-RS}IPSec VPN

十年老品牌
QQ咨询:450959328 微信咨询:togogozhong 咨询电话:020-38289118 咨询网站客服:在线客服

相关课程推荐

在线咨询 ×

您好,请问有什么可以帮您?我们将竭诚提供最优质服务!