集团站切换校区

验证码已发送,请查收短信

图标

学习文章

当前位置:首页 > >学习文章 > >

{思科CCIE-RS}OSPF选路规则-LSA5选路 基于IOS15.2 BY乱雪纷飞

发布时间: 2018-03-02 15:10:50

​LSA7的选路

metric-type 1

如果AD和COST相同,负载

如果COST不同,直接比较外部COST+内部沿途累加COST之和,优选计算结果小的

如果COST相同,将area-id大的LSA7的AD改大改小,都生效

如果COST相同,将area-id小的LSA7的AD改大改小,都不生效


metric-type 2

如果AD和COST相同,负载

如果外部COST不同,优选外部COST小的

如果外部COST相同,优选沿途累加接口COST小的

如果COST相同,将area-id大的LSA7的AD改大改小,都生效

如果COST相同,将area-id小的LSA7的AD改大改小,都不生效


拓扑



metric-type 1

1.如果AD和COST相同,负载

R1:

Router os 110

redistribute connected metric-type 1 subnets


R1-R4:

router ospf 110

area 123 nssa


R5:

Int f0/0

Ip ospf cost 3

!

Router ospf 110

Area 123 nssa

Area 567 nssa


R7:

Router os 110

redistribute connected metric-type 1

subnets


R6-r7:

router ospf 110

area 567 nssa


查看路由表



metric-type 1

2.如果COST不同,直接比较外部COST+内部沿途累加COST之和,优选计算结果小的

R1:

Router ospf 110

redistribute  connected

subnets metric-type 1 metric 1


查看路由表



metric-type 1

3.如果COST相同,将area-id大的LSA7的AD改大改小,都生效

R5:

access-list 3 permit

100.100.100.100

router ospf 110

distance 100 7.7.7.7 0.0.0.0 3


查看路由表



metric-type 1

4.如果COST相同,将area-id小的LSA7的AD改大改小,都不生效

R5:

access-list 3 permit

100.100.100.100

router ospf 110

distance 100 100.1.1.1 0.0.0.0 3


查看路由表



metric-type 1

5.如果COST相同,将area-id大的LSA7的AD改大改小,都生效

R5:

access-list 3 permit

100.100.100.100

router ospf 110

distance 120 7.7.7.7 0.0.0.0 3


查看路由表



metric-type 1

6.如果COST相同,将area-id小的LSA7的AD改大改小,都不生效

R5:

access-list 3 permit

100.100.100.100

router ospf 110

distance 100 100.1.1.1 0.0.0.0 3


查看路由表



metric-type 1

7.如果COST相同,将area-id小的LSA7的AD改大改小,都不生效

R5:

access-list 3 permit

100.100.100.100

router ospf 110

distance 120 100.1.1.1 0.0.0.0 3


查看路由表



metric-type 2

1.如果AD和COST相同,负载

R1/R7:

Router ospf 110

redistribute  connected subnets


R5:

Int f0/0

Ip ospf cost 3


​查看路由表



metric-type 2

2.如果外部COST不同,优选外部COST小的

R1:

Router ospf 110

redistribute  connected subnets  metric 1

查看路由表



metric-type 2

3.如果外部COST相同,优选沿途累加接口COST小的

R5:

interface FastEthernet0/0

ip address 56.1.1.5 255.255.255.0

ip ospf cost 1


查看路由表



metric-type 2

4.如果COST相同,将area-id大的LSA7的AD改大改小,都生效

R5:

access-list 3 permit

100.100.100.100

Router ospf 110

distance 100 7.7.7.7 0.0.0.0 3


查看路由表



metric-type 2

5.如果COST相同,将area-id大的LSA7的AD改大改小,都生效

R5:

access-list 3 permit

100.100.100.100

Router ospf 110

distance 120 7.7.7.7 0.0.0.0 3


查看路由表



metric-type 2

6.如果COST相同,将area-id小的LSA7的AD改大改小,都不生效

R5:

access-list 3 permit

100.100.100.100

Router ospf 110

distance 100 100.1.1.1 0.0.0.0 3


查看路由表





上一篇: {思科CCIE-RS}Type-1 LSA及Type-2 LSA的防环 BY乱雪纷飞

下一篇: {华为HCIE-RS}VLAN通讯原理(2)

十年老品牌
QQ咨询:450959328 微信咨询:togogozhong 咨询电话:020-38289118 咨询网站客服:在线客服

相关课程推荐

在线咨询 ×

您好,请问有什么可以帮您?我们将竭诚提供最优质服务!