集团站切换校区

验证码已发送,请查收短信

图标

学习文章

当前位置:首页 > >学习文章 > >

{思科CCIE-RS}OSPF选路规则-LSA5选路 基于IOS15.2 BY乱雪纷飞

发布时间: 2018-02-25 17:20:26

​LSA5:

metric-type 1

如果AD和COST相同,负载

如果COST不同,直接比较外部COST+内部沿途累加COST之和,优选计算结果小的

如果COST相同,修改router-id大的一方的路由的AD,无论改大改小,两条都生效

如果COST相同,修改router-id小的一方的路由的AD,无论改大改小,两条都不生效


metric-type 2

如果AD和COST相同,负载

如果外部COST不同,优选外部COST小的

如果外部COST相同,优选沿途累加接口COST小的

如果COST相同,修改router-id大的一方的路由的AD,无论改大改小,两条都生效

如果COST相同,修改router-id小的一方的路由的AD,无论改大改小,两条都不生效


拓扑


1.metric-type 1

如果AD和COST相同,负载

配置命令

R1:

Router os 110

redistribute  connected

subnets metric-type 1


R7:

Router os 110

redistribute  connected

subnets metric-type 1


查看路由表



如果COST不同,直接比较外部COST+内部沿途累加COST之和,优选计算结果小的

配置命令

R4:

interface FastEthernet0/0

ip ospf cost 100




如果COST相同,修改router-id大的一方的路由的AD,无论改大改小,两条都生效

R4:

access-list 3 permit

100.100.100.100

router ospf 110

distance 100 7.7.7.7 0.0.0.0 3


查看路由表



如果COST相同,修改router-id大的一方的路由的AD,无论改大改小,两条都生效

R4:

access-list 3 permit

100.100.100.100

router ospf 110

distance 120 7.7.7.7 0.0.0.0 3


​查看路由表


如果COST相同,修改router-id小的一方的路由的AD,无论改大改小,两条都不生效

R4:

access-list 3 permit

100.100.100.100

router ospf 110

distance 100 1.1.1.1 0.0.0.0 3


​查看路由表



如果COST相同,修改router-id小的一方的路由的AD,无论改大改小,两条都不生效

R4:

access-list 3 permit

100.100.100.100

router ospf 110

distance 120 1.1.1.1 0.0.0.0 3


查看路由表



如果AD和COST相同,负载

R1:

Router os 110

redistribute  connected subnets


R7:

Router os 110

redistribute  connected subnets


查看路由表



2.metric-type 2

如果外部COST不同,优选外部COST小的

R1:

Router os 110

redistribute  connected subnets metric 19


R7:

Router os 110

redistribute  connected subnets


查看路由表



如果外部COST同,优选外部COST小的

R1:

Router os 110

redistribute  connected subnets


R7:

Router os 110

redistribute  connected subnets


R4:

interface FastEthernet0/0

ip address 34.1.1.4 255.255.255.0

ip ospf cost 100


​查看路由表



如果COST相同,修改router-id大的一方的路由的AD,无论改大改小,两条都生效

R1:

Router os 110

redistribute  connected subnets


R7:

Router os 110

redistribute  connected subnets


R4:

access-list 3 permit

100.100.100.100

Router ospf 110

distance 100 7.7.7.7 0.0.0.0 3


查看路由表



如果COST相同,修改router-id大的一方的路由的AD,无论改大改小,两条都生效

R1:

Router os 110

redistribute  connected subnets


R7:

Router os 110

redistribute  connected subnets


R4:

access-list 3 permit

100.100.100.100

Router ospf 110

distance 120 7.7.7.7 0.0.0.0 3


​查看路由表



如果COST相同,修改router-id小的一方的路由的AD,无论改大改小,两条都不生效

R1:

Router os 110

redistribute  connected subnets


R7:

Router os 110

redistribute  connected subnets


R4:

access-list 3 permit

100.100.100.100

Router ospf 110

distance 100 1.1.1.1 0.0.0.0 3


查看路由表



如果COST相同,修改router-id小的一方的路由的AD,无论改大改小,两条都不生效

R1:

Router os 110

redistribute  connected subnets


R7:

Router os 110

redistribute  connected subnets


R4:

access-list 3 permit

100.100.100.100

Router ospf 110

distance 120 1.1.1.1 0.0.0.0 3


​查看路由表




上一篇: {华为物联网}华为物联网开发能力

下一篇: {思科CCIE-RS}OSPF选路规则-LSA3选路 基于IOS15.2 BY乱雪纷飞

十年老品牌
QQ咨询:450959328 微信咨询:togogozhong 咨询电话:020-38289118 咨询网站客服:在线客服

相关课程推荐

在线咨询 ×

您好,请问有什么可以帮您?我们将竭诚提供最优质服务!